Trying to run Umbrel over boringProxy to no avail

I’m not sure if the problem is specific to Umbrel, but i’ll detail the whole information here:

  • I set up a droplet on Digital Ocean
  • is setup in godaddy and both A and * are pointing to my droplet
  • am running boring proxy server there through
  • can access the control pannel from anywhere, no problem
  • Setup boringproxy client on my local Ubuntu 20.04 machine at home
  • this machine is running Umbrel (bitcoin node software)
  • Umbrel runs through http only, and can access it inside my local network through my computer’s IP
  • Has 2 ports exposed: 80 for the main Umbrel Dashboard and 2100 for the bitcoind node

these screenshots are taking from my mac, accessing the servers running on my Ubuntu PC:

on my Ubuntu machine:

Am i configuring something wrong ? or is it some kind of problem with Umbrel not allowing the tunneling?

Much appreciated, thank you

The main problem I see is that in your screenshot you’re attempting to access btc.***.com:2000. boringproxy is designed to only work over ports 80/443. Now, it does have some features for bypassing this, but in this case you won’t get at auto TLS management. It’s also been a while since I tested this functionality and it might not work anymore.

But basically you can try checking Allow External TCP and change the Tunnel Port to a known value (I’m guessing 2000 based on your example).

That would forward all TCP traffic directly from btc.***.com port 2000 to port 2100 on the client.

1 Like

Note that this assumes bitcoind uses TCP, not UDP. boringproxy doesn’t support UDP unfortunately.

1 Like

So where do i configure that my local server is running on port 2100 and that is the port i want to tunnel?

I believe you’re already doing that correctly, using the Client Port option. But I might be misunderstanding your question.

jesus, i didn’t see the fact that i was trying to access port 2100 from the browser.
Yeah, i’m sure that must be the problem…

I’ll have to try it later

Thank you