Ssh Dial error / ssh auth issue

i explained my issue on Github, any help is appreciated!

also i checked some related discussions still having issue to understand how the ssh auth should work.


Hey @TebbaaX, can you try running from the master build. it has a fix for some SSH issues:

Same Error, also the interface mentions that i can Override ssh server:port

Would you clarify how i should handle the ssh settings.


Ideally you shouldn’t have to manage any of the ssh stuff yourself. But you do need to have an ssh server running on the server on port 22, or tell boringproxy what port to use.

What happens if you download the ssh key manually from the server and trying connecting manually using the ssh command?

I am having the same issue. I was messing around with the ssh keys and now nothing works. Downloading the private key to my machine lets me connect to the server. Where should I put the keys on the client machine?

Okay, so I found in boringproxy_db.json that it tried to ssh as root, which I recently disabled that on the server. I changed the username in the file and now two out of three tunnels work. The third gives the same error, but that was working before too.

You’re not running boringproxy as root, are you? I don’t recommend that in general unless you’re in a VM, for security reasons.

Easiest thing might just be to start fresh. Create a backup of boringproxy_db.json and recreate your tunnels manually.

Hi! i do have ssh running on the server on port 22 (Running Boringproxy server on Digital ocean droplet and the client on my Ubuntu machine) what are the ssh connections i should manage to run between the two sides?


I did what you suggested, and it turns out, that I needed to set PermitRootLogin yes on the server sshd.config. Now it works again. Thank you.

Basically you need to use the boringproxy server web UI to manually download the private key for the SSH tunnel. Then, from the same machine you’re trying to run the client (WSL looks like?) try and manually create a remote forwarding tunnel using the private key you downloaded. See here for more information on what the command will look like:

You’ll want to add -i <privatekey> when you create the tunnel.

1 Like

@SierraThePotato I don’t recommend running boringproxy as root. If you want to carry on this conversation, please open a new thread so I can keep helping @TebbaaX here.


1 Like