No solvers available for remaining challenges on vultr vps

I have a VPS on Vultr and a homelab, I followed the instructions exactly from here and the video in the homepage, I have my A records set like this:

the white boxes being my VPS’s IPv4 address.

When I run from my VPS server ./boringproxy-linux-x86_64 server, and enter admin.MYDOMAIN as the domain to set, I get the no solvers available message (censored the private details):

YYYY/MM/DD hh:mm:ss MYDOMAIN: obtaining certificate: [MYDOMAIN] Obtain: [MYDOMAIN] solving challenges: MYDOMAIN: no solvers available for remaining challenges (configured=[http-01 tls-alpn-01] offered=[http-01 dns-01 tls-alpn-01] remaining=[dns-01]) (order= (ca=

If I run dig MYDOMAIN it does return the proper Ip adress of my vps and it says it’s an A record. is there anything I’m doing wrong?

I ran into something like this when I was using an underpowered VPS (512mb) with 10+ tunnels. If I lost connectivity in at home it would overload when my system would reboot. Adding one at a time would be fine until the whole system went down. Upgrading the VPS to a 1gb RAM solved it for me.