Everything is great, set it up in under 10 minutes, however, external tcp confusion


Im very new to networking, all i do is rent a vps and host a game server there, and done… but recently i build a new pc and my old pc is just there nothing to do with it. so i decided to set up a home server. all is working great, all the http works through the domain perfectly. im using casaos, like nextcloud, jellyfin, emby, i mean everything works.

except… crafty. a minecraft server controller which need external tcp allowed, and i ticked the checkbox.

i already set the gateway to clientspecified in the sdhc, and then

i create a tunnel, set my domain, set the client, set my local server ip, set the default minecraft port which is 25565, and allow external tcp - true. and then it gave me 37901 as the server tunnel port.

so basically the tunnel is created and everything is setup.

i run minecraft, and set the server address to my.domain.com:37901 , no luck… i tried my.domain.com:25565 , no connection.

is there anything i can do to make it work? i really need the help.

thank you so much!

best regards,

1- check my.domain.com resolves to your vps external IP ( ping my.domain.com )
2 - check if a firewall is not blocking the port on your vps

1 Like

I have the same issue, were you able to find a solution?