BoringProxy startup error

I just setup BoringProxy on my Ubuntu 18.04 server to enable access to a local website. When I try to start it I get the following message:

./boringproxy-linux-x86_64 server -admin-domain
2023/02/14 16:58:48 Starting up
WARNING: Failed to access from the internet
WARNING: Failed to access from the internet
2023/02/14 16:58:53 obtaining certificate: [] Obtain: [] solving challenges: no solvers available for remaining challenges (configured=[http-01 tls-alpn-01] offered=[http-01 dns-01 tls-alpn-01] remaining=[dns-01]) (order= (ca=

I could use some help on what I need to do to get this cleared up. Is it a problem with Let’sEncrypt?

These ports needs to be open

Thanks. My internet modem uses CGNAT, so no port forwarding. Is there any other option?

Getting around things like CGNAT is actually one of the main purposes of boringproxy. However, you need at least one device with a public IP address, which is where you run the boringproxy server. Typically people will use a VPS for this. Then you can run the boringproxy client behind CGNAT and it will use SSH to tunnel to the server, which proxies requests over the tunnel.

I get the same error, but it only happens, when I run boringproxy without sudo. If i start it as root, or with sudo, it works perfectly, so it’s not the firewall. What might be the cause of this?

You need root privileges in order to bind ports 80 and 443. Rather than running as sudo I recommend following the installation instructions and using setcap, which is more secure.

Okay, somehow I completely missed that when setting it up for the first time. Thank you!

1 Like